CM/MZ - Recording Duplicate Payment Transactions

Incident Report for ChamberMaster/MemberZone

Resolved

This incident has been resolved.
Posted Jan 22, 2026 - 13:30 CST

Update

Our teams have implemented a fix to mitigate the issue with recording duplicate payments from recurring. Meanwhile they will continue removing the duplicate payment records for you. As a reminder, these payments were not charged to your member twice, only recorded twice, please do not refund them. Thank you for your patience as we work through this issue.
Posted Jan 16, 2026 - 17:01 CST

Update

Our teams have implemented a fix to mitigate the issue with recording duplicate payments from recurring. Meanwhile they will continue removing the duplicate payment records for you. As a reminder, these payments were not charged to your member twice, only recorded twice, please do not refund them. Thank you for your patience as we work through this issue.
Posted Jan 15, 2026 - 11:57 CST

Update

We are continuing to monitor for any further issues.
Posted Jan 15, 2026 - 11:30 CST

Monitoring

Our teams have implemented a fix to mitigate the issue with recording duplicate payments from recurring. Meanwhile they will continue removing the duplicate payment records for you. As a reminder, these payments were not charged to your member twice, only recorded twice, please do not refund them. Thank you for your patience as we work through this issue.
Posted Jan 15, 2026 - 11:23 CST

Update

Our teams have identified, and are currently working on a fix for the issue with reporting duplicate payments. Meanwhile they will continue removing the duplicate payment records for you. Thank you for your patience as we work through this issue.
Posted Jan 14, 2026 - 14:21 CST

Update

We are continuing to work on a fix for this issue.
Posted Jan 13, 2026 - 11:54 CST

Update

We are continuing to work on a fix for this issue.
Posted Jan 12, 2026 - 07:43 CST

Update

We are continuing to work on a fix for this issue.
Posted Jan 09, 2026 - 16:26 CST

Update

We are continuing to work on a fix for this issue.
Posted Jan 09, 2026 - 13:07 CST

Identified

ChamberMaster/MemberZone engineers have identified an issue where duplicate payment transactions are being recorded in certain scenarios. In these cases only one payment was actually received. Please do not refund these, the payor was only charged one time. We are aware of the issue and will be removing the duplicate payment records for you as soon as possible. We are actively working to resolve the issue. Thank you for your patience.
Posted Jan 09, 2026 - 10:01 CST
This incident affected: ChamberMaster/MemberZone Database.