ChamberMaster/MemberZone app is currently unavailable
Incident Report for ChamberMaster/MemberZone
Resolved
This incident has been resolved.
Posted Jul 23, 2023 - 14:24 CDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 23, 2023 - 13:35 CDT
Update
We are continuing to investigate this issue.
Posted Jul 23, 2023 - 13:01 CDT
Update
We are continuing to investigate this issue.
Posted Jul 23, 2023 - 12:00 CDT
Update
We are continuing to investigate this issue.
Posted Jul 23, 2023 - 10:57 CDT
Investigating
We are currently investigating this issue.
Posted Jul 23, 2023 - 10:54 CDT
This incident affected: ChamberMaster/MemberZone Database and Integrated Website Modules.