Member Information Center (MIC) - slow to load or giving errors

Incident Report for ChamberMaster/MemberZone

Resolved

This incident has been resolved.
Posted Jun 17, 2026 - 15:32 CDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 17, 2026 - 15:18 CDT

Update

We are continuing to work on a fix for this issue.
Posted Jun 17, 2026 - 14:03 CDT

Identified

Member Information Center (MIC) — Known Issue
Some members may be experiencing slow page loads or errors when accessing the Member Information Center. Our team has identified the cause and is actively deploying a fix. If members report issues logging in or viewing their account, please let them know we are aware and working on it. We will update this message once resolved.
Posted Jun 17, 2026 - 11:52 CDT
This incident affected: ChamberMaster/MemberZone Application.