Email not accessible to our hosted email accounts
Incident Report for ChamberMaster/MemberZone
Resolved
This incident has been resolved.
Posted Feb 09, 2023 - 08:22 CST
Identified
We have identified the issue with our hosted email accounts and are working to correct it. Please note this does not affect our customers ability to send emails from ChamberMaster/MemberZone software, only those with email accounts hosted with us.
Posted Feb 09, 2023 - 08:12 CST
Investigating
We are aware that those customers using our hosted email service are experiencing access issues. There is a global outage with our provider and we will provide an update once we know more.
Posted Feb 09, 2023 - 08:02 CST
This incident affected: ChamberMaster/MemberZone Database.