Some customers not able to access ChamberMaster/MemberZone software
Incident Report for ChamberMaster/MemberZone
Resolved
This incident has been resolved.
Posted Mar 01, 2023 - 20:19 CST
Update
We are continuing to investigate this issue.
Posted Mar 01, 2023 - 20:18 CST
Investigating
We are currently investigating this issue.
Posted Mar 01, 2023 - 19:57 CST
This incident affected: ChamberMaster/MemberZone Database.