Some ChamberMaster/MemberZone customers are experiencing system slowness

Incident Report for ChamberMaster/MemberZone

Resolved

This incident has been resolved.
Posted May 13, 2025 - 14:41 CDT

Update

We are continuing to monitor for any further issues.
Posted May 13, 2025 - 13:00 CDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 13, 2025 - 11:55 CDT

Investigating

We are currently investigating this issue.
Posted May 13, 2025 - 10:40 CDT
This incident affected: ChamberMaster/MemberZone Database and Integrated Website Modules.