Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jan 26, 2026 - 22:00 CST
Scheduled
We will be performing infrastructure updates. During this time, there will be periods of time when the back office application and public modules are unavailable. Thank you for your patience.
Posted Jan 22, 2026 - 16:08 CST
This scheduled maintenance affected: ChamberMaster/MemberZone Database, Integrated Website Modules, GZ CMS Websites, SmartCMS Websites, Staff App for iOS and Android, and API.